iOS Push Notification Outage
Incident Report for Home Assistant
Resolved
We believe this issue is now resolved. If you are still experiencing issues, please try resetting your Push ID in the app and waiting 12 hours. If you continue to have issues after that, please contact us via Twitter or Discord.
Posted Aug 05, 2020 - 14:50 PDT
Update
We are continuing to work with Firebase Support on this issue. They believe they may have identified the problem with the way we are initializing the Firebase SDK in the app. Due to the lack of the Critical Alerts entitlement we can't submit a fix without disabling critical notifications for all users.

If you are experiencing this issue, you should attempt to reset your push ID as described in the earlier status message.

We expect to issue the next status update in 24 hours unless a major breakthrough is made.
Posted Jul 30, 2020 - 20:35 PDT
Investigating
iOS push notifications are currently intermittently working for most users. We are working with Apple and Firebase at the highest levels to resolve the situation as quickly as possible. Please monitor https://github.com/home-assistant/iOS/issues/850 for more granular updates.

We do not have a estimated time to service restoration. It is very likely that service will get worse before it begins to recover.

You may be able to temporarily recover push notifications by going into the app's notification settings screen and tapping Reset button below the Push ID.

Please note: This only affects Home Assistant Companion for iOS, not Android or any third party mobile apps.
Posted Jul 29, 2020 - 20:32 PDT
This incident affected: Services (Push Notifications).