A fix has been implemented and we are monitoring the results.
Posted Nov 18, 2025 - 07:55 PST
Update
Cloudflare has implemented a fix for the incident affecting its global network and support services. They have stated that they “believe the incident is now resolved” and are continuing to monitor for any residual errors.
Services are now mostly accessible. We continue monitoring.
Posted Nov 18, 2025 - 07:25 PST
Identified
We are currently experiencing intermittent errors and degraded performance in our Community Forums and Websites due to an ongoing incident affecting Cloudflare’s global network. Cloudflare has reported an internal service degradation impacting several of its application services, which we rely on for secure access and traffic delivery.
Between approximately 11:48 UTC and 13:35 UTC on 18 Nov 2025, Cloudflare identified the issue and began rolling out fixes. They report that some services have already recovered and error rates are returning to normal, though remediation efforts are still in progress on their side.
Cloudflare is implementing a fix and reports partial recovery. Our systems are stable, but we continue to monitor them closely and will update this page if we observe any further impact.
Posted Nov 18, 2025 - 05:45 PST
This incident affected: Content (Website, Developer Docs, Data Portal), Forums (Forums), and Cloudflare.